Black Friday email processing
Incident Report for Dotdigital
Resolved
This incident has been resolved.
Posted Nov 26, 2021 - 15:04 GMT
Monitoring
Hey folks! Black Friday is the biggest email sending day of the year (as you know). Many more emails are being sent around the world by everybody, which means it can take a little extra time to process them (when compared to a normal day). Our platform is already equipped to manage the additional volumes we’re expecting to see today. We want to reassure you campaigns will complete successfully and there’s no additional actions you need to take.
It’s important to mention. When emails leave our mail servers and are accepted by the receiving mail servers (at gmail, Hotmail, yahoo, etc), they need to pass through their infrastructure and filtering before arriving into recipient inboxes. Receiving mail servers are processing vastly elevated volumes today, which may take them longer than usual.
Posted Nov 26, 2021 - 10:17 GMT