Problems with EasyEditor for Safari users
Incident Report for Dotdigital
Postmortem

Summary of impact:

At approximately 06:40 UTC on 14 September 2022, as part of the fortnightly release, we released a change for EasyEditor affecting how it operated for Mac/Safari users. During this time, Mac/Safari users experienced issues with designing and saving email campaigns. The change we made was part of a beta release related to our ‘Product Blocks’ feature. The resolution for the issue was to revert this change. We restored full EasyEditor functionality for Mac/Safari users at 10:50 UTC on 14 September 2022.

Root Cause:

We deployed code that called a function not supported by the Safari API. The call to that method crashed Safari during the loading cycle of EasyEditor, meaning the remainder of EasyEditor couldn’t load successfully.

Mitigation:

A summarized timeline of events (in UTC):

  • 06:40: We deployed the change that impacted how EasyEditor operated in Safari
  • 08:45: We were alerted to the issue and begun working on a resolution
  • 10:50: We rolled back the change in question, meaning EasyEditor in Safari began to operate as expected.

Next Steps:

From here, we’ll:

  • Investigate options to navigate around the missing method in the Safari API
  • Review our testing plans and capabilities for Mac/Safari.
Posted Sep 14, 2022 - 15:10 BST

Resolved
A fix has been implemented and the issue is now resolved. We’ll write a detailed description of what caused the issue, it’ll be posted on here as soon as it’s ready (in a day or two).
Posted Sep 14, 2022 - 11:55 BST
Identified
We've identified the issue and we're working on a fix which will be released soon.
Posted Sep 14, 2022 - 11:24 BST
Investigating
We've discovered an issue preventing Safari users from saving campaigns in Easy Editor, and our tech team are working flat out to fix it. Sorry if this is affecting you, but things should be back to normal very soon. Look out for more news from us shortly.
Posted Sep 14, 2022 - 10:39 BST