Degraded performance with tracking links using ddlnk.net
Incident Report for Dotdigital
Postmortem

RCA: Tracking issues when using ddlnk.net

Summary of impact:

At approximately 06:39 UTC on 3rd January 2023, our domain registrar disabled the ddlnk.net domain without notice due to receiving abuse reports. We restored services at 12:00 UTC on 3rd January 2023.

During this time, any customers who don’t use their own branded domain for emails, may have experienced the following issues:

  • Some recipients may have been unable to click on links within emails.
  • Some open and click data may be absent from account Analytics.

Root Cause:

The domain ddlnk.net was disabled by our domain registrar after receiving abuse reports. We didn’t receive prior notice before our domain registrar disabled ddlnk.net. We’re waiting for more information from our domain registrar on the nature and source of these reports. 

Our platform provides link tracking and forwarding of links to URLs on the internet. Our customers and trialists can add links in their emails and SMS that may forward to URLs hosting unwanted content, malware or viruses. As the domain ddlink.net is used for email link tracking and forwarding, an unsafe URL being added to an email campaign could trigger abuse complaints to our domain registrar. Our Messaging Compliance Team proactively monitor abuse complaints for unsafe URLs and prevent those accounts from sending. This activity stops the majority of unsafe links from being used.

Mitigation:

The timeline (in UTC) for resolving this issue was:

  • 10:37 - We contacted our domain registrar to report the issue
  • 12:00 - We observed our ddlnk.net domain started to show signs of working as normal
  • 12:16 - We received confirmation from our registrar they had reactivated our ddlnk.net domain

Next Steps:

In order to prevent this issue from happening again, we’ll continue to work with our registrar to understand why the domain was suspended and why we were not notified prior to this happening.

Posted Jan 04, 2023 - 11:44 GMT

Resolved
Everything is back on track now.
We’ll write a detailed report for the issue we’ve experienced today. It’ll be posted on here as soon as it’s ready (in a day or two).
Apologies about today’s mishap.
Posted Jan 03, 2023 - 13:32 GMT
Monitoring
The domain ddlnk.net has now been restored by our domain registrar and service has been restored.
Posted Jan 03, 2023 - 12:09 GMT
Identified
We have identified an issue with degraded performance with email tracking links using the ddlnk.net domain. Customers using our alternative default tracking domains or those with custom from addresses are not impacted. Sorry if you're affected, but our tech team are working as quickly as possible to resolve the issue and get things back to normal. We'll share another update shortly.
Posted Jan 03, 2023 - 11:16 GMT
This incident affected: North America - Dotdigital R2 (North America - Open and Link Tracking), Europe - Dotdigital R1 (Europe - Open and Link Tracking), and Asia Pacific - Dotdigital R3 (Asia Pacific - Open and Link Tracking).