Engagement Cloud - Issue with External Dynamic Content - All Regions
Incident Report for dotdigital
Postmortem

Summary of impact:

At approximately 13:22 BST on Wednesday 14th August 2019, it was identified that any campaigns containing External Dynamic Content sent since the scheduled maintenance at 7:30am of the same day would have failed, and have automatically been cancelled.

Related back end infrastructure services were shutdown to prevent any further campaigns containing External Dynamic Content from failing.

Service was restored at 15:03 BST.

Root cause:

As a part of our regular maintenance window new code was deployed that unfortunately contained an error that directly affected External Dynamic Content.

Mitigation:

Service was restored after the error had been identified and an emergency update released.

Next steps:

Enhanced testing procedures will be introduced to prevent a recurrence.

Posted 2 months ago. Aug 15, 2019 - 11:57 BST

Resolved
The identified issue has now been resolved and service has been restored. We apologise for any inconvenience this problem has caused you. An incident report will be available in the next few days when we have fully understood the root cause of the issue.
Posted 2 months ago. Aug 14, 2019 - 15:03 BST
Identified
The issue has been identified and our teams are working on deploying a fix as soon as possible.
Posted 2 months ago. Aug 14, 2019 - 13:49 BST
Investigating
We are currently investigating an issue with customers being unable to use External Dynamic Content thus resulting in campaigns containing EDC being cancelled.

Further updates will be provided in due course
Posted 2 months ago. Aug 14, 2019 - 13:46 BST