Intermittent issues with (inbound) Support telephone lines
Incident Report for dotdigital
Resolved
We're pleased to say the issues with our phone lines are now resolved. Customer calls have continued to arrive successfully throughout the day. We're sorry if you experienced any delays or trouble calling our team over the past couple of days.
Posted Oct 14, 2021 - 16:41 BST
Monitoring
We've continued to work with our third-party provider to resolve the intermittent issues with phone lines into our Support and Customer Service Team. We're seeing a vast improvement in our ability to answer customer calls and lines now appear to be operating as normal. We're going to monitor performance and provide another update later today. Sorry if you've had to try a couple of times to get through to us.
Posted Oct 14, 2021 - 10:06 BST
Identified
We're currently experiencing intermittent issues with the phone lines into our Support and Customer Service Team which is affecting our ability to answer customer calls. We're working with our third-party provider to resolve the issue.
Livechat and email support are operating as normal and should be used until the issues are resolved:
- Livechat: Can be launched from any helpcentre page, from inside our Dotdigital application or this direct link
- Email: support@dotdigital.com
We're sorry this issue has occurred, however, we're happy to make outbound calls if requested to do so (from Livechats/emails).
Posted Oct 11, 2021 - 10:34 BST