We are investigating an issue with login to our platform in Europe region
Incident Report for dotdigital
Resolved
This issue is now deemed fixed.
Posted 5 months ago. May 10, 2019 - 15:24 BST
Monitoring
We believe this issue to be fixed now but will be monitoring for a while longer and we'll update shortly.
Posted 5 months ago. May 10, 2019 - 15:13 BST
Investigating
Update to be provided soon.
Posted 5 months ago. May 10, 2019 - 14:49 BST