Intermittent issues loading Dotdigital
Incident Report for Dotdigital
Postmortem

Summary of impact:

At approximately 17:15 UTC on Tuesday 25th Ocotber 2022, we were alerted to connectivity issues on our platform. During this time, customers experienced issues when trying to gain access to their Dotdigital account and certain areas of the platform were not loading as expected.

Root Cause:

We isolated the problem to be with a 3rd party provider, Cloudflare. Cloudflare have since announced the incident was caused by an incorrect network configuration change which disrupted traffic in some of their largest data centers. You can find the full details of the incident on the Cloudflare blog post Partial Cloudflare outage on October 25, 2022

Mitigation:

At 18:50 UTC,  Cloudflare resolved the issues with their network. This meant access to our platform was restored.

Next Steps:

We’ve asked Cloudflare to continue their investigation into this incident and to identify any mitigating steps they can take to prevent future issues.

Posted Oct 26, 2022 - 14:03 BST

Resolved
Our third-party technology provider has confirmed that this issue is now resolved. We’re sorry for any interruption it caused.
Posted Oct 25, 2022 - 20:16 BST
Update
Our third party technology partner have implemented a fix. We're keeping a watchful eye on things to make sure it stays that way. We'll let you know when we’re 100% confident everything is fully back to normal.
Posted Oct 25, 2022 - 19:37 BST
Monitoring
Our third-party technology provider has implemented a fix for this issue and is currently monitoring the situation to confirm there is no recurrence.
Posted Oct 25, 2022 - 19:36 BST
Identified
We're investigating an issue with intermittent issues loading Dotdigital in your web browser. Sorry if you're affected. The issue is due to a partial outage at a third party technology provider who are having issues. We'll share another update shortly.
Posted Oct 25, 2022 - 18:45 BST