Issues with Support Livechat
Incident Report for Dotdigital
Resolved
We’ve monitored the situation for some time now and we’re confident this issue is fully resolved.
Sorry it happened and for the interruption it caused.
Posted Mar 15, 2022 - 12:32 GMT
Monitoring
All LiveChat Support functionality is now restored.
We're keeping a watchful eye on things to make sure it stays that way. We'll let you know when we’re 100% confident everything is fully back to normal.
Posted Mar 15, 2022 - 10:51 GMT
Identified
We're currently experiencing issues with Livechats into our Support and Customer Service Team. Our Support & Customer Service Team are currently unable to receive/answer any Livechats due to these issues. If you need to contact us urgently, you can use support@dotdigital.com or find our telephone numbers here: https://support.dotdigital.com/hc/en-gb/articles/360011229880.
Posted Mar 15, 2022 - 10:01 GMT